communication trouble w/4.619

Communication trouble w/4.619, a forum discussion on Cleverscope. Join us for more discussions on Communication trouble w/4.619 on our Questions forum.

Back to Forum Index : Back to Questions   RSS

16 Oct 2007
Posts: 27

I tried both the updater and full install with 4.619, in either case I get the pop up message "USB problem". I reinstalled the previous version, and it works. ???

16 Oct 2007
Posts: 27

this was with a CS328 and windows XP.

17 Oct 2007
Posts:

I am also having USB problem on my laptop with Windows XP home.
The USB 2.0 PCMCIA card (two different ones) do not work reliably at all, even with different devices (Flash drives) so I know that there is a Windows driver issue and there is no updated one.
The Cleverscope works for a few seconds before the error occurs.
The same cards work fine if I boot Linux so it is not the cards.
However, I never had any problems with the USB 1.x built-in port on this computer but Cleverscope keeps timing out and resetting USB and I get only fragments of the acqusition.

The same software (v4.619) works perfectly on my desktop computer with the same Cleverscope unit on Windows 2000.

The question are:
- Windows 2000 better than XP?
- Laptop hardware (or drivers) worse than desktop

Let's get a survey going so that we can narrow this problem down.
I hate to buy another laptop and have the same problem.

17 Oct 2007
Posts: 73

Hi,
Thanks for the input and we do need further feedback. We have been having problems with the third party USB driver for some months and had thought that 4619 had resolved them. Using a CS328A I have tried a direct USB 1.0 as well as a PCMICA USB 2.0 and a USB expansion box with USB 1.0. The direct connect is the most reliable but the others do operate after a few protests.

Regards,
Roger

18 Oct 2007
Posts: 27

I have a Dell Precision 390 workstation, and am using the direct USB connection. (no USB card being used)

19 Oct 2007
Posts:

All I can say is that I cannot make v4.619 work on my laptop reliably, I get USB errors on USB2.0 and USB1.x.
I could not even upload the firmware. I had to use my desktop computer to do it.
The same laptop used to work fine with the older version prior to v4.615 but I cannot remember which one (v4.612?)
v4.619 works fine on my desktop computer but this is not how I want to use it.

When you are talking about the USB driver which file in perticular?
Maybe I can try different ones.
I do not see them being changed between versions and all of the USB files seem to be somewhat old.

20 Oct 2007
Posts: 73

After further testing we believe the problem is with the ROM version 6422, not with the software 4.619. The confusing factor is that it is only a problem with some hardware. If you load 6420 (which is in the same release) then the USB problems should disappear. The only feature that is then missing is the true auto function. We have pulled 6422 until we can resolve the problem.

We did try an older driver (QuickUSB.sys dated 26/07/04 rather than 24/04/06) which did seem to help but did not eliminate the problem.

20 Oct 2007
Posts:

I also got this error on my desktop computer so it is not related only to my laptop.

Then, I downloaded v6420 and it seems to work on both, my desktop and my laptop with the USB 2.0 PCMCIA card.
I had it running for more than 30 minutes without any USB problems except when laptop went hibernating.

I think you are on the right track and I hope you solve this problem soon.

23 Oct 2007
Posts: 399

Ok - just to confirm, v4.619, and now 4.620 application software are reliable with firmware v6420. However v6422 is flawed. We think we have got to the bottom of it, and hope to post new firmware shortly. We will keep you posted.
Back to Forum Index : Back to Questions   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.

×

Your shopping cart is empty.