Calibration not working - need support in getting scope working again

Calibration not working - need support in getting scope working again, a forum discussion on Cleverscope. Join us for more discussions on Calibration not working - need support in getting scope working again on our Questions forum.

Back to Forum Index : Back to Questions   RSS

27 Jan 2009
Posts: 13

Hello Cleverscope. I've sent a couple e-mails to the support e-mail address in the past week, but haven't gotten any response, so I'll post here in hopes of reaching one of the great folks at Cleverscope with this request.

Logic (where I work) has purchased several Cleverscopes, and mine (serial AG4071 – which is a CS328A) will not calibrate itself. (I’ve been having lots of problems getting channel B to display in certain voltage ranges, so I tried to calibrate the scope.) When I try to do a self-calibrate, it will get stuck on the Do Self Calibration screen, Standard tab. After clicking Start Self Calibration, I get a complete % = 0.5, a Phase of + Low Ranges and it just sits there for as I leave it (>30 minutes). I am running Cleverscope software 4.634, and have Firmware version 6435 installed on this CS.

Is there anything I can do, or do I need to send it back to you for repair? If I need to send it back for repair, please contact me and let me know how to do so in an expeditious manner. We really do need both channels working.

Sincerely,

*Brian Schmalz

12 Feb 2009
Posts: 395

Hello Brian - just confirming that we got the unit, fixed it, sent it back, and you were happy. (""I got the Cleverscope back today, and it appears to work great! Thanks so much for fixing it for me."").

Everyone else - the CS328A includes a self test, which tests all power supplies, the memory system, the internal module ID system, and a fairly comprehensive front end test. If you disconnect the probes from the Cleverscope, and then power up the unit, the Green Power LED should come on, and then the RED Trigger LED should flash a few times, and go out. If it stays on, the self test failed. (Each flash is a test).
If this happens the unit might not calibrate, and you should send it back to your distributor, or us, for repair. The Classic CS328 has a simpler self test. If the green LEd does not come on, the self test failed, and you will need to return to us.

13 Feb 2009
Posts: 13

Yes yes! I should have posted a follow-up message as soon as I got the scope back from you. So sorry!

For everyone- Bart was away from e-mail for a little while, which is why my original inquiry did not get answered right away. Bart had me do a couple of simple tests to narrow down the problem, and then had me ship it back to him for repair when he determined that there wasn't anything I could do on my own to fix it. Didn't cost me anything, and he was very, very quick in repairing it and getting it back to me. Stellar service all around - I'm very pleased that my company has chosen to buy CleverScopes and I recommend them whenever I can. Having a great service experience like this reinforces the good vibes.

One thing to note: my CleverScope was (I believe) running for quite some time with the self-test failing. Just because the POST fails doesn't mean that it will refuse to work. There was a problem, the CleverScope was detecting it, but I didn't know enough to realize what the red LED meant. I kept using the scope (only one channel had a problem) thinking everything was OK. So be sure to check yours.

Thanks again Bart!

*Brian
A very satisfied customer

30 Jan 2014
Posts: 2

Hi CleverScope,

I have an CS328A FG4278 (Excellent product), at least five years old now, so its far out of any warranty. I'm having the same problem as Brian had and after reading the post I noticed the red trigger light remaining on when powered up. Everything seems fine but channel B has some random steps and the trace is only good for a rough reference.

Is there anything I can check on the PCB circuit around channel B that gives the most common problems that I might be able to repair on my own?

Best regards,

Barry

31 Jan 2014
Posts: 395

Hello Barry,
From what you are saying it sounds like the self test is failing which is the reason you have this problem. We are happy to repair the unit at no charge, provided you send it back to us. Please verify the self test - disconnect front panels probes, power off, and power on. If the red trigger light stays on, that is a failed self test.

please email us with your details using the on-line form which you can find in Contact us.
regards

Bart

31 Jan 2014
Posts: 2

Your email advice worked Bart.

Reseating the CS71X board solved the problem, looks like it was just a dodgy connection. everything works perfectly again.

Thanks again for the quick and friendly service.

Barry

Back to Forum Index : Back to Questions   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.

×

Your shopping cart is empty.