Ethernet CS328A-XSE: software keeps accessing through USB

Ethernet CS328A-XSE: software keeps accessing through USB, a forum discussion on Cleverscope. Join us for more discussions on Ethernet CS328A-XSE: software keeps accessing through USB on our Interface issues forum.

Back to Forum Index : Back to Interface issues   RSS

9 Oct 2010
Posts: 13

Dear Colleaques,

I just received, unpacked, installed and connected a brand new CS328A-XSE. After a few trials I got the IP addresses configured - the scope is connected directly to the laptop without DHCP, and fixed IP addresses are set for both the laptop and the scope unit. The scope unit gets properly recognized in the ""Choose acquirer & set connection dialog"", and the 'Interface Source"" is set as ""Ethernet - Find by IP address"".

When I close the ""Choose acquirer & set connection"" dialog, and try to acquire my first trace, by pushing the Acquire -> Auto button in the Cleverscope Control Panel, I get the message ""Warning: there is a problem with the USB port. Check that cables are properly plugged..."" . As if the software still thinks the connection should be through USB and not through the Ethernet. Rebooting the laptop or unpowering the scope don't seem to help. Suggestions about what to do?

The software is version 4.649, installed by the full installer which I downloaded from the Cleverscope web page. I unchecked the 'Install USB drivers' option during the installation procedure - I thought I'm not going to use the drivers anyway, and the more unnecessary drivers you load to your system the greater the chance of instability. Perhaps it is the missing USB driver which gives?

Regards,
Mikko

9 Oct 2010
Posts: 13

Tried installing the USB drivers, too. The situation did not change, the same symptoms. Still complains about a bad USB connection, although the connection method is (I think) configured as Ethernet.

Regards,
Mikko

9 Oct 2010
Posts: 401

Hello Mikko,
We have a problem with the warning - we will change it so that it says Ethernet or USB. Currently it says USB, even if Ethernet is configured. You do need the Visa driver, otherwise it will not be able to communicate. You don't need the USB driver. If you are using direct PC access please be sure to follow the instructions starting at section 14.2 in the manual.

Some key points are:
1. That you have configured both the PC and the Scope for fixed IP.
2. That the IP address first three digits match between the PC and the scope.


We use UDP for making the initial connection and setting up the scope. (UDP is connection-less, and so it is not important that the IP addresses match). We use TCP/IP for the actual data transfers (which use point-to-point connections). If the IP addresses don't match you can't talk.

I suggest you work through section 14.2 and follow what you see directly. Let us know how you go.


Regards - Bart

11 Oct 2010
Posts: 13

It was the missing VISA driver. Because the installer offered an option to *not* load the driver (and I prefer to not pollute my system with unnecessary drivers), I thought the driver is not vital and perhaps only needed for accessing the hardware from my own LabView code. Now I realize that the entire CleversScope application is written in LabView.

Now the scope runs wonderfully - I'll keep on experimenting with its capabilities. Thanks for the help!

Regards,
Mikko
Back to Forum Index : Back to Interface issues   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.

×

Your shopping cart is empty.