Trigger problem

Trigger problem, a forum discussion on Cleverscope. Join us for more discussions on Trigger problem on our Questions forum.

Back to Forum Index : Back to Questions   RSS

21 Jul 2013
Posts: 2

Hi

I have a problem with triggering I would very much appreciate your opinion about.
As shown in the screenshot, the triggering happens at the ‘second’ rising-edge part of the waveform, and not at the beginning/first rising-edge of the waveform as I would like.
I have tried different trigger settings and threshold levels, but with the same result. Do you have any suggestions to why this happens, and how I might be able to trigger on the first part of the waveform?

I have the CS328A, USB version, with function generator. Serial AG4020
Newest firmware version 6463 5338. App version 4672. HW version 3.6. Windows 7 (64bit)

Best regards,
Pete

25 Jul 2013
Posts: 395

Hello Pete,
Well this is a curly one! Can you please explain it a bit more - we notice the trigger is in Auto, and you have the trigger tool active. Was the screen shot captured with the setup that you have (ie you have a system putting out decaying sine pulse sets)? Or had you changed the trigger level after capturing the signal.

The reason I say that is the trigger has hysteresis of 5% of the full scale amplitude. If the trigger setting where closer than 5% above 0V (about 20mV for your setup), then the first rising edge would not meet the trigger spec, but the second would. For the trigger level you show (27 mV) it's close, but should have been ok. I suggest you make the trigger level a bit higher.

When we tried to do some thing same we got it triggering properly.

3 Aug 2013
Posts: 2

Hi Bart
Thanks for helping, and sorry for my late response.
As far as I remember the screen shot of the scope graph was taken with the same trigger settings as shown in the screen shot of the trigger settings, but I’m not absolutely sure – perhaps I did change the settings between capturing the two screen shots.
I did try a lot of different trigger levels between 1 to 100 mV, but with the same result where the triggering happens at the ‘second’ rising-edge part of the waveform. I also tried both rising and falling edge triggering.

I suspect it happens because it’s not exactly a standard/pure decaying sine pulse, although it very much appears this way in the screenshot.
The signal is measured directly from a small sensing coil with a value of 200mH, with a 47kohm resistor in parallel which dampens and decays the sine. The sensing coil receives it’s signal by magnetic induction from another nearby transmitting coil, which is connected to a generator.

The generator waveform is not a simple impulse or step function (which I guess would produce a normal decaying sine, and hopefully make the scope trigger on the first rising-edge part of the waveform, as you have succeeded in doing on your screen shot), but is instead a periodic squarewave. I guess this square results in a non-uniform decaying sine, since it’s time period is shorter than the time it takes for the sensing coil signal to fully decay to 0V (i.e. the generating square frequency is higher than the sensing coil resonance frequency). On the screen shot, the first negative pulse part of the waveform is strangely larger in amplitude than the first positive pulse part, which is probably because the square wave shifts polarity at this part of the waveform. Do you think this might be what disturbs the triggering?

Anyways, the easiest solution will probably be that I try with an ordinary step signal (or low frequency square wave) and see if this makes it trigger correctly. I will try this as soon I get back from vacation, and let you know the result. Have a nice holiday.

Best regards,
Pete
Back to Forum Index : Back to Questions   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.

×

Your shopping cart is empty.