USB interface error message when using ethernet scope

USB interface error message when using ethernet scope, a forum discussion on Cleverscope Mixed Signal USB Oscilloscopes. Join us for more discussions on USB interface error message when using ethernet scope on our Installation Issues forum.

Back to Forum Index : Back to Installation Issues   RSS
BruceG

7 Aug 2023
Posts: 3

Model: CS328A
Serial no: DK5685
OS: Windows 11

Whe I attempt to acquire waveforms after installing latest version of sthe oftware A USB connection error messasge pops up.
bartschroder

7 Aug 2023
Posts: 477

Hello Bruce,
If you are using the Ethernet connection, you need to set it up properly. You will find that in the manual,
section 23, page 150.

Here is a download link for the manul:
https://www.cleverscope.com/files/Cleverscope%20manual%20v2-13.pdf

The dialogs have changed a bit in the latest app, but the intent is the same.
You will need to know if you are using a DHCP server (the easiest), or a fixed IP network. Once you know this, follow through the chapter.

Please let me know how you go.

The message still says USB, even though it is an Ethernet fault. In the next version it will be a more generic message.
BruceG

7 Aug 2023
Posts: 3

I did that, when I first tried it. Still same result when I press auto triggering button.

The Scope is directly plugged into my HP Probook laptop via a short ethernet cable.

The last time I did this albeit with a different laptop (Toshiba) (no longer available) and an earlier version of the Cleverscope and an earlier version of Windows app worked without an issue. Howvere this was at least a couple of years ago
bartschroder

7 Aug 2023
Posts: 477

Hi Bruce,
This is the hardest way to connect (DHCP is by far the easiest).
You will need to verify that the PC can see the Cleverscope before bothering with Auto. Until there is Comms nothing will work.

First verify that your laptop, which will have two Ethernet Ports (Wifi and Wired), has the wired port set to Fixed IP - step 5 on page 155. There will be two adapters. Don't modify the Wifi adapter settings as this means you may not be able to communicate. Set an IP address you can remember - eg 192.168.1.2

Second Open 'Choose Acquirer and set connection' in the App and look at the right hand side and you will see an 'Ethernet NIC to use'. Choose the wired NIC - it should have the address you just programmed.

If you have the Cleverscope Ethernet plugged in, you should see your scope under 'Local Ethernet Cleverscopes found'. Select it by clicking on it. It should be green high lighted. Next click on 'Edit Local Ethernet', and select 'Use Static IP address' and enter a IP address with the first three numbers the same, and the last number different - eg 192.168.1.3, then click 'Update Address'. Then click Close.

After a moment, the status should change back to 'Available', and the Connection to 'Static IP'.

If all this happens, click 'OK', and then clicking Auto should display captures.
Let me know how it goes.
Bart

BruceG

7 Aug 2023
Posts: 3


Thanks, I was a little rusty not having used the scope for a long time, but I managed to work out how to configure it as you stated above but with the addition of temporarily disabling the wifi before it worked.
I was also able to acquire the NTSC waveform from the video camera and confirm that it was actually NTSC albeit modified where the black and blank levels are identical.
This should be enough info to configure the NTSC to SDI converter correctly.
Back to Forum Index : Back to Installation Issues   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.

×

Your shopping cart is empty.